6 заметок с тегом

Google

  • Google — крупнейшая в интернете поисковая система, принадлежащая корпорации Google Inc.
    Первая по популярности система (79,65 %), обрабатывает 41 млрд 345 млн запросов в месяц (доля рынка 62,4 %), индексирует более 25 млрд веб-страниц, может находить информацию на 195 языках.
  • Google Inc. — американская транснациональная публичная корпорация, инвестирующая в интернет-поиск, облачные вычисления и рекламные технологии. Google поддерживает и разрабатывает ряд интернет-сервисов и продуктов и получает прибыль в первую очередь от рекламы через свою программу AdWords. Компания основана Ларри Пейджем и Сергеем Брином. Впервые она была зарегистрирована как частная компания 4 сентября 1998 года, а 19 августа 2004 года начала продажу своих акций на фондовом рынке. Тогда Ларри Пейдж, Сергей Брин и Эрик Шмидт договорились о совместной работе в Google в течение двадцати лет, до 2024 года. Заявленной миссией компании с самого начала была «организация мировой информации, обеспечение её доступности и пользы для всех», а неофициальный лозунг компании, придуманный инженером Google Полом Бакхейтом: «Не будь злом» (англ. Don’t be evil). В 2003 году компания переехала в свою нынешнюю штаб-квартиру в Маунтин-Вью (штат Калифорния).

Настройка DoH в Mikrotik

Второго дня в версии 6.47 ветки stable завезли поддержку DoH (DNS over HTTPS). До этого оно было только в ветке с beta и использовать ее не очень хотелось в виду отсутствия стабильности. Почему это так важно? Дело в том, что DNS без каких-либо дополнений дает возможность вышестоящему провайдеру смотреть и подменять dns-запросы. Не видно причин, зачем ему давать такое делать. А также есть некая простота в том, что теперь свои dns-запросы не нужно заворачивать в тот же VPN.

DNS поверх HTTPS (DoH) — протокол для выполнения разрешения DNS по протоколу HTTPS. Целью этого метода >является повышение конфиденциальности и безопасности пользователей путём предотвращения перехвата и >манипулирования данными DNS с помощью атак типа «Атака посредника».

Первым делом нужно обновиться до 6.47 в ветке stable (или воспользовать beta). В случае с long-term стоит либо потерпеть и подождать или переключиться на stable.

Далее идем в IP -> DNS. Сразу же стоит обратить внимание, что вы можете получать DNS динамически (вышестоящий провайдер или настройки APN) и надо бы убрать автоматику. Чаще всего выглядит это как-то так:

Теперь нужно провести небольшую артподготовку, а именно скачать и импортировать список корневых сертификатов. Делается это двумя командами:

/tool fetch url=https://erza.ru/cert/cacert.pem
/certificate import file-name=cacert.pem passphrase=""

Также список корневых сертификатов можно взять на сайте haxx.se или же с DigiCert

После чего удалим лишние dns-серверы и впишем свои. В итоге у нас все выглядит вот так:

Провести проверку можно с помощью torch или в connection tracker:

Список DoH серверов — смотреть тут, но самые популярные скорее всего будут Google ( https://8.8.8.8/dns-query ) и Cloudflare ( https://1.1.1.1/dns-query ).

Тестируем и проверяем на сайте Cloudflare

На всякий случай привожу листинг команд:

/tool fetch url=https://erza.ru/cert/cacert.pem
/certificate import file-name=cacert.pem passphrase=""
/ip dns set use-doh-server=https://1.1.1.1/dns-query
/ip dns set verify-doh-cert=yes
/ip dns set servers=""

UPDATE: Никита Тарикин набросал еще более интересную штуку со скриптом и поворотами — MikroTik DNS-over-HTTPS CloudFlare :)

 Нет комментариев   5 мес   Cloudflare   DNS   DoH   Google   https   Mikrotik   VPN

Gooooogle Girl

Gooooogle Girl — милый такой клип от MAD SHOW BOYS, не настолько токсичный как Google that shit! от Тарин Саутерн .

Странные проблемы с Google DNS

Сегодня где-то в половине шестого начались странные проблемы с интернетом. По цепочке проверили все, что только можно, пока не уперлись в dns от Google. Порядка трех часов из сети Ростелекома, с М9 и из сети Билайн было не получить ответа. Фокус в том, что пинги проходили нормально (потери были, но небольшие и непостоянные), а вот ответ не отдавался или отдавался с большими потерями. Забавное в том, что началось все с основного 8.8.8.8. Резервный адрес 8.8.4.4 работал нормально, правда потом начал хандрить и он.

Что это такое было не ясно, но больше всего сообщений мной было найдено из РФ. В англоязычном части интернета авария прошла незаметно (впрочем может её там и не было). Никаких официальных ответов или сведений об этом инциденте нет.

Проверять можно следующим образом:

nslookup google.com 8.8.8.8
dig @8.8.8.8 google.com

В качестве резерва есть днс серверы от Яндекса:

77.88.8.8
77.88.8.1

UPDATE, 22:00 — подборка новостей по теме:

Провальный поиск шаблона

Совершенно неожиданный результат иногда получаешь при поиске, казалось бы, незначительной вещи (исправление предложено, обид нет, но в остальном..):

Изменения в ритме

Прошел месяц после перехода на новую работу, а я все никак не могу привыкнуть к новому ритму. Организму сложно перечеркнуть последние пять лет сменных графиков 2-2-3, перейдя на привычную многим пятидневку. Начал замечать за собой, что после прихода домой стоит только ненадолго прилечь, почти гарантированно засыпаю. Складываются схемы: пришел-прилег-уснул, пришел-поужинал-уснул, пришел-приготовил ужин-уснул. Не знаю, сколько уйдет времени на адаптацию, месяца оказалось мало. Из плюсов могу заметить, что ходить пешком стал больше. По ощущениям нижние конечности стали крепче. Около трех с копейками километров ежедневно дают о себе знать. Даже Google Now обратил мое внимание на небольшое достижение :)